/operate/ - Endchan Operations

Let us know what's up

Posting mode: Reply

Check to confirm you're not a robot
Name
Email
Subject
Comment
Password
Drawing x size canvas
File(s)

Remember to follow the rules

Max file size: 350.00 MB

Max files: 5

Max message length: 4096

Manage Board | Moderate Thread

Return | Catalog | Bottom

Expand All Images


(4.98 KB 376x44 no image.png)
(4.88 KB 379x44 no image 2.png)
no images ? Anonymous 10/26/2017 (Thu) 16:58:02 [Preview] No. 7301
There's a problem in that images aren't displayed anymore, can you fix? Was it an update that broke it?

I'm on tor but it's not a browser problem because images work on 8ch and some images here too (I can see the ones on /operate/ front page for example).

Pics related.


Anonymous 10/29/2017 (Sun) 12:33:55 [Preview] No. 7349 del
Bump for actual issue.


to_sha_ki#xs0+7l 10/29/2017 (Sun) 12:39:15 [Preview] No. 7350 del
same problem has happend in /librejp/ also since 3 days ago.
about 700 or more images have already disappeared from some posts.
it is still ongoing.

(* /librejp/ are NSFW board)
>>>/librejp/95882
There were 289 images in this thread before. currently there are 6 images.
>>>/librejp/37990 ; 379 images -> 9 images
>>>/librejp/23123 ; 100 images -> 2 images
there are others.

there is no log that images was deleted with role power.


Anonymous 10/30/2017 (Mon) 16:25:57 [Preview] No. 7364 del
bump
don't let /pol/ slide this


Anonymous 10/30/2017 (Mon) 20:37:55 [Preview] No. 7365 del
autopurge erroneously selecting non-orphaned images?


odilitime Board volunteer 10/31/2017 (Tue) 11:10:26 [Preview] No. 7372 del
shit the only major change around that time was an upgrade to node 8.x

I can roll back to 7.x to see if the issue goes away


Anonymous 11/01/2017 (Wed) 00:05:05 [Preview] No. 7381 del
>>7365
I don't think that is the case.
I don't remember any bug like that and I just made a test where a file was deleted while being actually in use and the result was that the post just displayed a broken file, see image.

The test was performed on 1.9, I manually set the reference count of the file to 0 and then ran -pf. This command runs the same routine that prunes files weekly. And even then, endchan have this feature disabled.


odilitime Board volunteer 11/01/2017 (Wed) 08:47:14 [Preview] No. 7389 del
>>7372
We're back on 7.x, let me know if is this problem still exists or goes away.


Anonymous 11/01/2017 (Wed) 12:09:24 [Preview] No. 7398 del
I did find an issue with lynxchan.
When using board deletion, it would treat posts with a null ip as valid targets for deletion, thus deleting all posts with null ips if any of these were selected.

However, this feature ignores file deletion, so I don't if its what caused the files to be missing.

Can any board or global mod tell me if these posts have an ip associated with them? And if so, do they have different ips or all belong to the same one?


Anonymous 11/01/2017 (Wed) 12:28:16 [Preview] No. 7400 del
>>7398
when using board ip deletion*


Anonymous 11/01/2017 (Wed) 12:54:57 [Preview] No. 7401 del
And an useful information the site staff could provide is that if these posts have any files attached to them on the db.

There is a chance its something up going on the templating that is just removing the area the files are put.


Anonymous 11/01/2017 (Wed) 14:38:00 [Preview] No. 7406 del
I'm also pretty sure the issue is not with node 8. This is a very clean issue to be caused by a runtime environment issue.


to_sha_ki#xs0+7l 11/02/2017 (Thu) 23:30:16 [Preview] No. 7442 del
>>7389
file loss in /librejp/ has not occurred from 5 days ago.

but there is one more problem.
75 thread pages are in the 404 state currently.
I confirmed it around 10 o'clock of GMT+0.

this problem has occurred for the second time.
the first time was around (10:00 GMT+0) of 4 days ago.
at the first time, these pages returned to normal after posting or waiting for a few hours.

webpage capture:
https://endchan.xyz/librejp/res/24686.json http://archive.is/wvMBE
https://endchan.xyz/librejp/res/24730.html http://archive.is/oUqsr
https://endchan.xyz/librejp/res/25472.html http://archive.is/3ZFin
https://endchan.xyz/librejp/res/25472.json http://archive.is/67Eks


odilitime Board volunteer 11/04/2017 (Sat) 11:44:09 [Preview] No. 7477 del
>>7442
at the beginning of the night, these were 404 but now they're not. I did edit settings, enabling verbose, rebuild templates, and restart lynx a couple times. Something must have fixed these.

Let me know if anything else breaks.

>has not occurred from 5 days ago.
StephenLynx: do you think a one-time board deletion nuked these, not the node version?

to_sha_ki: was >>7350 one time or ongoing until I downgraded (>>7389) ?


Anonymous 11/04/2017 (Sat) 15:51:49 [Preview] No. 7481 del
>>7477
I have no idea what could have caused the deletion, but I am pretty sure it wouldn't be node 8.

I am inclined to guess it was some change on your fork, but can't tell anything for sure without knowing a way to replicate it or without further information on the posts that had their files deleted.


to_sha_ki#xs0+7l 11/05/2017 (Sun) 15:59:46 [Preview] No. 7497 del
>>7477
the last loss of media files occurred about that time of this post >>7350
until then, media file loss occurred every few hours.
the downgrade you did is 2 days later.



Top | Return | Catalog | Post a reply